Hello, i'm having trouble with MCDzienny software, it dosen't work on mono. mono version:

Mono JIT compiler version 5.18.0.240 (Debian 5.18.0.240+dfsg-5 Tue Sep 10 13:23:34 UTC 2019)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS:           __thread
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  amd64
        Disabled:      none
        Misc:          softdebug
        Interpreter:   yes
        LLVM:          supported, not enabled.
        Suspend:       preemptive
        GC:            sgen (concurrent by default)
----10/7/2019 12:07:58 PM ----
Type: TypeLoadException
Source: MCDzienny_
Message: Could not load type of field 'MCDzienny.SQLiteMono:transConnection' (3) due to: Could not load file or assembly 'Mono.Data.Sqlite, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9>
Target: ExecuteQuery
Trace:   at MCDzienny.DBInterface.ExecuteQuery (System.String queryString, System.Boolean createDB) [0x0001a] in <76a4a56aa2e94af4b427ced9e7bc75ed>:0
  at MCDzienny.DBInterface.ExecuteQuery (System.String queryString) [0x00000] in <76a4a56aa2e94af4b427ced9e7bc75ed>:0
  at MCDzienny.Database.DBManager.CreateAlterPlayersTableSQLite () [0x00000] in <76a4a56aa2e94af4b427ced9e7bc75ed>:0
  at MCDzienny.Database.DBManager.Initialization () [0x00124] in <76a4a56aa2e94af4b427ced9e7bc75ed>:0

----10/7/2019 12:07:58 PM ---- Type: FileNotFoundException Source: MCDzienny_ Message: Could not load file or assembly 'Mono.Data.Sqlite, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' or one of its dependencies. Target: ExecuteQuery Trace: at MCDzienny.SQLiteFront.ExecuteQuery (System.String queryString, System.Collections.Generic.Dictionary`2[TKey,TValue] parameters) [0x00007] in <76a4a56aa2e94af4b427ced9e7bc75ed>:0 at MCDzienny.DBInterface.ExecuteQuery (System.String queryString, System.Boolean createDB) [0x0001a] in <76a4a56aa2e94af4b427ced9e7bc75ed>:0 at MCDzienny.DBInterface.ExecuteQuery (System.String queryString) [0x00000] in <76a4a56aa2e94af4b427ced9e7bc75ed>:0 at MCDzienny.Level.Load (System.String givenName, System.Byte phys, MCDzienny.MapType mType, System.Boolean autoUnload) [0x0009d] in <76a4a56aa2e94af4b427ced9e7bc75ed>:0

-------------------------
----10/7/2019 12:07:58 PM ----
Type: FileNotFoundException
Source: MCDzienny_
Message: Could not load file or assembly 'Mono.Data.Sqlite, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' or one of its dependencies.
Target: fillData
Trace:   at MCDzienny.SQLiteFront.fillData (System.String queryString, System.Collections.Generic.Dictionary`2[TKey,TValue] parameters, System.Boolean skipError) [0x00007] in <76a4a56aa2e94af4b427>
  at MCDzienny.DBInterface.fillData (System.String queryString, System.Boolean skipError) [0x0001a] in <76a4a56aa2e94af4b427ced9e7bc75ed>:0
  at MCDzienny.DBInterface.fillData (System.String queryString) [0x00000] in <76a4a56aa2e94af4b427ced9e7bc75ed>:0
  at MCDzienny.Level.Load (System.String givenName, System.Byte phys, MCDzienny.MapType mType, System.Boolean autoUnload) [0x00244] in <76a4a56aa2e94af4b427ced9e7bc75ed>:0

Server version: 12.2.0.0

I can't access pastebin in my country, sorry.

AndrewPH ᕕ( ᐛ )ᕗ 🅱️arude your 🅱️andstorms ᕕ( ᐛ )ᕗ Sun Oct 6 at 18:46:14 (2019)

Please enclose your log in codeblocks then by using three backticks (```) on each end of the log

like
this
please

Do you have the sqlite3 package installed? You can check it with the command dpkg -l | grep sqlite and install with apt-get install sqlite3

Yes, i have:

ii  libmono-sqlite4.0-cil                                       5.18.0.240+dfsg-5            all          Mono Sqlite library (for CLI 4.0)
ii  libqt5sql5-sqlite:amd64                                     5.12.5+dfsg-2                amd64        Qt 5 SQLite 3 database driver
ii  libsqlite0                                                  2.8.17-15+b1                 amd64        SQLite 2 shared library
ii  libsqlite0-dev                                              2.8.17-15+b1                 amd64        SQLite 2 development files
ii  libsqlite3-0:amd64                                          3.30.1-1                     amd64        SQLite 3 shared library
ii  libsqlite3-0:i386                                           3.30.1-1                     i386         SQLite 3 shared library
ii  sqlite                                                      2.8.17-15+b1                 amd64        command line interface for SQLite 2
ii  sqlite3:i386                                                3.30.1-1                     i386         Command line interface for SQLite 3

And don't use apt-get, it is deprecated, use apt instead.